Audi A1 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
811 Posts
Discussion Starter · #1 ·
<language filter on>

OK so I know we've had really bad weather but these lot are taking the ....

Many, many people who haven't had deliveries from them including me. Local depot is suggesting 5 day delay.

So if everything is THAT bad, how come I've received two lots of parcels via Royal Mail this morning. The first was sent on the 20th First Class from Manchester, the second sent yesterday by Special Delivery from Glasgow. But my City Link sent last week for next day delivery is nowhere to be seen. And it's not Xmas pressies - it's business software which is needed ASAP.

Funnily (but not funny) enough this happened before with an earlier version of the exact same bit of software. Paid for next day via City Link but it never arrived as the driver was off sick. Following day was a Saturday and we hadn't paid for Saturday delivery! So got into car (Audi A3 then) to go and buy it from a shop only to be caught in a 8 hour closure on the M11!

But they only lost £5.6M last year - things are looking up as they lost £43.5M the year before.

<language filter off>
 

·
Registered
Joined
·
30 Posts
Screw City link! All about TNT!!! Depends maannn because the weather is a **** - for example that ash cloud but sometimes it does come down to human error... I know what goes on in those depots and I wouldn't be far from the truth when I say it's alot of easten european people throwing boxes around... Not trying to scare you or anything but it might be worth calling their customer service up?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top